Author Topic: Crashes on startup (El Capitan)  (Read 931 times)

Offline dauphin

  • Newbie
  • **
  • Posts: 7
Crashes on startup (El Capitan)
« on: December 26, 2015, 01:47:35 PM »
Porting Kit runs fine on my MacBook Pro but on my newly built Hackintosh it crashes immediately on startup.  Both are running El Capitan 10.11.2 so there seems to be something about the Hackintosh that's causing a problem.  I've saved a crash report but can't see a way of attaching it.

Offline vitormm

  • Developer
  • Administrator
  • Legendary Porter
  • *****
  • Posts: 530
Re: Crashes on startup (El Capitan)
« Reply #1 on: December 26, 2015, 11:59:51 PM »
Here is the button that you need to press to attach something. Press Reply and you will find it.


Offline dauphin

  • Newbie
  • **
  • Posts: 7
Re: Crashes on startup (El Capitan)
« Reply #2 on: December 27, 2015, 09:18:23 AM »
Thanks, I saw the Attachments button before and it seemed the obvious thing to try.  But it doesn't appear to give any option to attach!  Maybe I'm being stupid but I noticed another poster also could not see how to attach - or perhaps I need a minimum number of postings before being allowed to attach?

Offline 112madgamer

  • WSI Developer
  • Global Moderator
  • Journeyman Porter
  • *****
  • Posts: 132
Re: Crashes on startup (El Capitan)
« Reply #3 on: December 27, 2015, 01:13:40 PM »
Hey here is some help with attachments so Click Attachments and other options then Browse choose text file then post easy as pie!






Also why would you like to run PK on a hackintosh when you can just run windows just interested?
« Last Edit: December 27, 2015, 01:19:17 PM by 112madgamer »

Offline vitormm

  • Developer
  • Administrator
  • Legendary Porter
  • *****
  • Posts: 530
Re: Crashes on startup (El Capitan)
« Reply #4 on: December 27, 2015, 01:30:19 PM »
Also why would you like to run PK on a hackintosh when you can just run windows just interested?

He probably don't want to use Windows, just like us :P we also can install Windows in boot camp but we prefer using ports.

Anyway, that's like 112madgamer showed. The problem with attachments in the other ports was a long time ago and was already solved. Anyone can upload anything as long as it doesn't weight more then 25Mb (which in fact is too much; I think I inserted one zero more than the necessary, it should be 2.5Mb).

Offline dauphin

  • Newbie
  • **
  • Posts: 7
Re: Crashes on startup (El Capitan)
« Reply #5 on: December 27, 2015, 01:51:54 PM »
Thanks, but I don't get all those options when I click on Attachments.  I just see Notify me of replies; Return to this topic; Lock this topic; Don't use smileys.  No option to make an attachment!
I can paste text of the crash report in a message if that's OK. but it's pretty long.
In answer to the question raised: I just built this machine as a "pure" Hackintosh without Windows.

Offline vitormm

  • Developer
  • Administrator
  • Legendary Porter
  • *****
  • Posts: 530
Re: Crashes on startup (El Capitan)
« Reply #6 on: December 27, 2015, 01:58:21 PM »
Thanks, but I don't get all those options when I click on Attachments.  I just see Notify me of replies; Return to this topic; Lock this topic; Don't use smileys.  No option to make an attachment!
I can paste text of the crash report in a message if that's OK. but it's pretty long.
In answer to the question raised: I just built this machine as a "pure" Hackintosh without Windows.

Fixed the problem. You should be able to attach now.

Offline dauphin

  • Newbie
  • **
  • Posts: 7
Re: Crashes on startup (El Capitan)
« Reply #7 on: December 27, 2015, 02:07:08 PM »
Thank you!  Here it is....

Offline vitormm

  • Developer
  • Administrator
  • Legendary Porter
  • *****
  • Posts: 530
Re: Crashes on startup (El Capitan)
« Reply #8 on: December 27, 2015, 06:25:36 PM »
This is very strange. It seems to be a system problem that is causing it, but I'm not sure. I'm gonna check it deeply. In the meanwhile, try to use the latest Porting Kit; I think it's your best beat: http://portingkit.com/kit/Porting%20Kit%201.8.66.zip

Offline dauphin

  • Newbie
  • **
  • Posts: 7
Re: Crashes on startup (El Capitan)
« Reply #9 on: December 27, 2015, 07:43:53 PM »
Thanks for the suggestion.  I've just tried that version but it also crashes almost immediately.  Please don't go to too much trouble but I'll be interested if you do come up with an answer.  Apart from PK, the Hackintosh is running great and seems very stable.

Offline dauphin

  • Newbie
  • **
  • Posts: 7
Re: Crashes on startup (El Capitan)
« Reply #10 on: December 28, 2015, 12:13:36 PM »
Just occurred to me - I'm using the Nvidia drivers, could the problem be related to that?

Offline vitormm

  • Developer
  • Administrator
  • Legendary Porter
  • *****
  • Posts: 530
Re: Crashes on startup (El Capitan)
« Reply #11 on: December 30, 2015, 04:35:21 PM »
I'm not sure. I assume that the problem lies here:

"Faulting in NSHTTPCookieStorage singleton"

Offline dauphin

  • Newbie
  • **
  • Posts: 7
Re: Crashes on startup (El Capitan)
« Reply #12 on: January 21, 2016, 03:34:14 PM »
I'm pleased to report that after the El Capitan 10.11.3 update - and installing the Nvidia drivers for 10.11.3 - this issue has been resolved.  Not sure which of those updates made the difference, but the main thing is that it now works!

Offline vitormm

  • Developer
  • Administrator
  • Legendary Porter
  • *****
  • Posts: 530
Re: Crashes on startup (El Capitan)
« Reply #13 on: January 21, 2016, 08:25:12 PM »
I'm pleased to report that after the El Capitan 10.11.3 update - and installing the Nvidia drivers for 10.11.3 - this issue has been resolved.  Not sure which of those updates made the difference, but the main thing is that it now works!

That's great! ;D

Offline JokerGregor

  • Gamer
  • ***
  • Posts: 19
Re: Crashes on startup (El Capitan)
« Reply #14 on: March 06, 2016, 10:25:42 PM »
Just want to mention that I got the attachment problem too, but then I just tried drag&drop, that works at least for me fine. For those who have the problem still aswell  ;)