Author Topic: Links in description don't load correct GOG page  (Read 823 times)

Offline Bradamante

  • Gamer
  • ***
  • Posts: 20
Links in description don't load correct GOG page
« on: August 01, 2016, 06:15:18 PM »
In the Porting Kit app, when I click a link in the description of a library title, the click goes to the browser, but the correct link is not getting loaded. The URL changes to gog.com/games.

I tried for Unreal Tournament 2004 and Rune, and they show the described behavior.

Offline vitormm

  • Developer
  • Administrator
  • Legendary Porter
  • *****
  • Posts: 957
Re: Links in description don't load correct GOG page
« Reply #1 on: August 02, 2016, 02:28:16 PM »
In the Porting Kit app, when I click a link in the description of a library title, the click goes to the browser, but the correct link is not getting loaded. The URL changes to gog.com/games.

I tried for Unreal Tournament 2004 and Rune, and they show the described behavior.

I couldn't reproduce that. Tried that links in the description and the links in the GOG.com icons, and both opened the correct link  :-\

Someone else is experiencing this issue?

Offline Bradamante

  • Gamer
  • ***
  • Posts: 20
Re: Links in description don't load correct GOG page
« Reply #2 on: August 31, 2016, 07:50:57 PM »
Did some more testing.

Clicking the GOG icon of a game also does not work (before I only tried clicking the link in the description). Also, setting the system default browser from Firefox to Safari did not change the behavior, it still goes to gog.com/games. Note: this is all with my library items!

Clicking the Steam logo link on a online library game works (goes to instant-gaming.com/...) + GOG logo/description link works (I tried Mound & Blade).

Offline vitormm

  • Developer
  • Administrator
  • Legendary Porter
  • *****
  • Posts: 957
Re: Links in description don't load correct GOG page
« Reply #3 on: September 02, 2016, 11:52:44 AM »
Did some more testing.

Clicking the GOG icon of a game also does not work (before I only tried clicking the link in the description). Also, setting the system default browser from Firefox to Safari did not change the behavior, it still goes to gog.com/games. Note: this is all with my library items!

Clicking the Steam logo link on a online library game works (goes to instant-gaming.com/...) + GOG logo/description link works (I tried Mound & Blade).

So the GOG links in the website (http://portingkit.com/games/) works but the ones in the Porting Kit application don't?

Offline Bradamante

  • Gamer
  • ***
  • Posts: 20
Re: Links in description don't load correct GOG page
« Reply #4 on: September 02, 2016, 01:16:09 PM »
I am not talking about the website, I am only testing the local PK app. There, the local links don't work, but links from the online database work (library/local vs library/server).

Offline vitormm

  • Developer
  • Administrator
  • Legendary Porter
  • *****
  • Posts: 957
Re: Links in description don't load correct GOG page
« Reply #5 on: September 02, 2016, 02:02:04 PM »
I am not talking about the website, I am only testing the local PK app. There, the local links don't work, but links from the online database work (library/local vs library/server).

Owwww, now I understand :P

I will check it out as soon as possible. Thanks for the warning :)