Author Topic: ORIGIN PROBLEM - PLEASE HELP  (Read 234 times)

Offline Renburgandy

  • Newbie
  • **
  • Posts: 3
« on: January 05, 2019, 04:09:43 PM »
Hi guys, I resisted posting this for a long time having recently discovered the Porting Kit tool, and have really, really tried to do this without having to ask (I hate having to ask for tech support), but I'm so stuck, and I feel like I'm going round in circles.

I actually have all of the old C&C games on CD's'DVD's still, but I paid and registered for the 17 game bundle via Origin.

I have tried to install Generals, Red Alert 2 and several others that require a Windows Origin install, but it just will not work for me. I have read many other threads, but it does not seem a simple problem.

I will now details everything I am doing to try an install C&C Generals, and if I am going wrong somewhere, please do tell me afterwards.

1. Launch Porting Kit
2. Search C&C Generals
3. Click Install
4. Box pops up:

If you never installed a game from Origin before, we recommend you to watch the instructions first. If you already know how to do it, buy it before trying to install. If you already have it, then install it now.

I have it, so click "INSTALL NOW"

5. Dialog Box pops up

Click "Next", "I Agree"

6. WSI downloads
7. Select Port Destination (I just keep this the same and click "install")
8. Installation of various things begin. "Configuring Wrapper". Winetrick etc installed...

Now the problems begin... (or I believe they are a problem)

9. "Installing Origin Background... "

At this point, every single time I have tried I get several dialog boxes... as below:

Access Denied
File Not Found
Something wrong happened while installing Origin. Do you want to perform the installation manually by selecting an installer?

Now I can do one of two things:

1. I click yes, and point it at the Origin installer exe file that I downloaded from the origin website.
2. I click No... and it says:

You didn't installed OriginSetup.exe, which is needed by Origin. Do you want to continue anyway?

If I say "Yes", the installer then carries on and I get the following two dialog boxes:


"the installation was successful".

Now I click "Play".

I get the following:

So having read around a few different posts on here, I have found that to get this to run I must change the configuration within Wine. So I click "More" and then "Wine Configuration", and change the default and origin.exe configurations to "Windows 7".

I click "Play" again.

Wine begins to run, and origin opens. With the following box

I click "install origin"

I choose the following options on the next page:

And click "Continue"

Origin begins Installing. "Installing the latest version of Origin"

Origin finishes installing, and login screen pops up.

"Online login is currently unavailable".

Trying to log in brings up "You be online when logging in for the first time".

And this is as far as I can seem to get on ANY of the Origin ports (all of the command and conquer series games, that I have now paid for via Origin).

I also read on other posts about closing this dialog box and it will install properly... This does not seem to do anythiing for me either.

I don't know where I'm going wrong, but I do seem to get a lot of error boxes popping up no matter which path I seem to take.

Would love to play these old C&C games on my Mac again. If anyone can spot where I'm going wrong, I would love it.

Also, I really hate sounding like a noob, so I'm already embarrassed having to ask but I have really tried on my own, but I must be missing something.

Thanks in advance!

Also here is my mac info:


  • Guest
« Reply #1 on: January 11, 2019, 02:37:41 AM »
Soooo... am I the only person having problems installing Origin and Origin Games then??


  • Guest
« Reply #2 on: January 12, 2019, 04:20:34 PM »
No I'am having similar problems installing RA2 and yuri's revenge.

With me the error begins after the install of origin. Then the loginscreen appears which states that is is not possible to login because of it is offline, i think here starts the problem.

First i waited for more than 30 min for something to happen, then i forced quit.

Trued again. but then i try to login, then the bar turns red, saying it had no internet connection. when i quit this window by pressing the x, the setup treis to continue but then gives the error cannot find file. and then it asks for a link to file ''originthemethin.exe'' and then it is over agian.

Plz help greetingzz


  • Guest
« Reply #3 on: January 18, 2019, 10:39:58 PM »
any update or help on this i have the same issue...?


  • Guest
« Reply #4 on: January 20, 2019, 07:49:39 PM »
I'm getting the same error messages coming up when trying to download/play RA2. Tried for a few hours yesterday using different paths but none of them ended up successful.


  • Guest
« Reply #5 on: January 23, 2019, 11:29:17 PM »
I'm having the same problem when trying to download C&C Tiberium wars and kane's wrath :\

Offline Bosque10

  • Newbie
  • **
  • Posts: 1
« Reply #6 on: January 29, 2019, 06:59:06 PM »
Aye, myself as well. :/

Offline Blond1305

  • Newbie
  • **
  • Posts: 1
« Reply #7 on: February 19, 2019, 09:55:34 PM »
Thé sale problème Wilhelm Bf1942!! :'(