Author Topic: Skyrim wrapper no longer working  (Read 619 times)

IFM

  • Guest
Re: Skyrim wrapper no longer working
« Reply #15 on: November 29, 2018, 11:30:00 AM »
I have the exact same problem.  I got a little closer by reinstalling the wine engine but that only gets you as far as the CONTINUE screen at which point the entire mac freezes and you have to power down.   

Glad to see this isn’t isolated to me but sad that Steam seems to have broke it.  :(

Quint

  • Guest
Re: Skyrim wrapper no longer working
« Reply #16 on: December 04, 2018, 10:05:11 AM »
Hey guys, i'm running LE on Mojave, and after a few search i ended up finding this solution :

1) When opening PK, go to Skyrim : Click "More/Advanced"

2) Wineskin Tools -> Wineskin Config

3) Go to the "Library" tab

4) Write in "New override for Library" : "gameoverlayrenderer.dll" without the quotes, then press Add.

5) Click on your new override and then click "Edit"

6) Set it to "disabled," click apply and ok, and enjoy !

Credits goes to sancheziumfluoride08 for finding that override, hope it will work you guys.

xx


Malkhut

  • Guest
Re: Skyrim wrapper no longer working
« Reply #17 on: December 04, 2018, 07:11:22 PM »
Great !  Thank you so much Quint for this fix. It's working ! By the way, I use High Sierra, so I think it should work with other macOS versions as well... 8)

Greg

  • Guest
Re: Skyrim wrapper no longer working
« Reply #18 on: December 05, 2018, 06:47:54 AM »
That was it! Thank you Quint for the help!

guest1234

  • Guest
Re: Skyrim wrapper no longer working
« Reply #19 on: December 05, 2018, 05:43:02 PM »
Thanks for the fix. Now it starts and freezes as soon as I load or start a game. Anyone else with that problem?

Offline viviandarkbloom

  • Newbie
  • **
  • Posts: 3
Re: Skyrim wrapper no longer working
« Reply #20 on: December 05, 2018, 09:08:32 PM »
Hey guys, i'm running LE on Mojave, and after a few search i ended up finding this solution :

1) When opening PK, go to Skyrim : Click "More/Advanced"

2) Wineskin Tools -> Wineskin Config

3) Go to the "Library" tab

4) Write in "New override for Library" : "gameoverlayrenderer.dll" without the quotes, then press Add.

5) Click on your new override and then click "Edit"

6) Set it to "disabled," click apply and ok, and enjoy !

Credits goes to sancheziumfluoride08 for finding that override, hope it will work you guys.

xx

Awesome! This solved the issue I was having with Fallout: New Vegas too. Thank you!!

flyingbison

  • Guest
Re: Skyrim wrapper no longer working
« Reply #21 on: December 06, 2018, 04:56:37 PM »
When I click the “Wine Config” under the more tab upon clicking the Skyrim game, it attempts to open skyrim and I do not get anything on the screen. With this solution, are there any other tips that could be helpful with getting this override to work?

Offline vitormm

  • Developer
  • Administrator
  • Legendary Porter
  • *****
  • Posts: 903
Re: Skyrim wrapper no longer working
« Reply #22 on: December 09, 2018, 03:02:56 PM »
The fix seems to work in my side as well. Just included the fix in the port. Could anyone else check if the port is working now? Btw, you need to reinstall the port in order to use the fix.