Post reply

Warning - while you were reading 26 new replies have been posted. You may wish to review your post.
Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Name:
Email:
Subject:
Message icon:

Verification:

shortcuts: hit alt+s to submit/post or alt+p to preview


Topic Summary

Posted by: habdankm
« on: October 02, 2016, 01:56:36 PM »

I'm using GOG and it should at least be DRM Free:
https://www.gog.com/game/anno_1404_gold_edition
Posted by: paulthetall
« on: October 02, 2016, 09:47:40 AM »

This has todo with Copy protection/DRM which wine in quite some cases can't handle correctly like for example with TAGES and some Securom versions. GOG.com version doesn't contain DRM/Copy protection, which eliminates that problem.
Posted by: habdankm
« on: September 21, 2016, 07:05:45 PM »

Hi

I have MacBook Pro (Retina, Mid 2015) with Intel Iris Pro 1536MB and PortingKit 2.4 installed.
I've set DirectXVersion to 9 but still have exactly same issue as described above. Only lowering details to LOW and resolution to 1/2 of retina resolution (1280x800 for Mac 13" and 1440x900 for Mac 15") solve the problem. Can I help somehow to find an issue to create a patch which will solve the problem? Game is playable, but I love hires graphic in this game and if it possible I would like to try apply some changes which might help.
Any ideas where to start?

Best

Mikolaj
Posted by: Steef Sinkeler
« on: September 15, 2016, 03:31:19 PM »

Hey Paul,

thanks for the quick reply. I have updated to the latest Porting Kit version, without succes.
However, lowering the graphic settings further indeed solved the problem.
Now playing at 1024x768 with graphic settings at Low, but at least I can play.
Thanks for the wonderful work on the port and the quick help!
Posted by: paulthetall
« on: September 13, 2016, 03:33:34 PM »

Hey Steef!

Latest Portingkit version? I played about 2 hours without issues on my intel HD 5000.
Intel HD has much less videomemory, so it might be related to that. How does it play with minimum settings but 1280x800 resolution?
Posted by: Steef
« on: September 13, 2016, 03:26:17 PM »

Unfortunately no, this didn't fix it for me.

Running a MBP early 2011 with Intel HD 3000. Downloaded the GOG version.
Totally random, yesterday I played for an hour, today it immediately crashes after loading the save games (tried different save games).

Video quality set to medium.
Posted by: paulthetall
« on: June 10, 2016, 09:15:05 AM »

Ok guys, update to latest portingkit, and let me know the results :) hopefully this was the problem and should be fixed now :)
Posted by: paulthetall
« on: June 06, 2016, 10:15:00 AM »

Anyone having an Intel Iris or Intel HD gfx card with the problem? I have a theory about this this one..but to confirm that I need to know if there is someone with an Intel HD/Intel Iris gfx card with the same problem.

For the ones with Nvidia/AMD Radeon: Try this:
in porting Kit go to local tab --> select game --> more --> start wineskin --> advanced --> tools --> winetricks --> select under the settinsg --> set videomemorysize to 1024mb --> run the trick and
try again. Also make sure that in screensettings (in the "start wineskin" menu), that detect videocard is "not" selected.

Let me know.
Posted by: vitormm
« on: June 05, 2016, 06:05:41 PM »

this problem still exists for. ANNO gives me the error message and after the 2nd or 3rd time it does it crashes. i'm on the AMD Radeon HD 6970M but i read that is might have to do with the 32bit app not playing nicely with 64bit wine and not being able to allocate RAM?

Well, all Wineskin engines available in the Porting Kit only create 32 bit prefix wrappers, so I guess that's not the case :P
Posted by: Stonelord Woodsman
« on: June 05, 2016, 05:07:04 PM »

this problem still exists for. ANNO gives me the error message and after the 2nd or 3rd time it does it crashes. i'm on the AMD Radeon HD 6970M but i read that is might have to do with the 32bit app not playing nicely with 64bit wine and not being able to allocate RAM?

Hmm, I never get any error messages of any kind. Not even when the app crashes.
Posted by: Stonelord Woodsman
« on: June 05, 2016, 05:03:34 PM »

What also might be an issue and what I see more coming up is the ratina display. Macdriver may force the resolution to that native Retina view what extremely increases the videomemory usage. So also try to lowe resolution to for Macbooks 1280x800 and IMacs 1600x900. and see how that works out.

Reason is of this theory is that I played the game for more then an hour and finished the first level and started the second one without issues.
There will be portingkit update today which adresses intel HD GFX memory. If you guys have an Intel HD gfx card, then this update will most likely solve your problem (crashing after about 15 min. So check the news blog when it gets released and update your porting Kit straight away that time. And let us know the results.

Thanks for letting us know Paul. On my end, I have a Nvidea card. I'm wondering how does the PK update help this problem exactly? Does it apply a patch the wrapper?

Lowering the resolution did help for me last time I tried that. I ended up reverting because it was a bit ugly, but I guess I'll put it back to a lower setting.

The thing is, Paul, I remember that the first level and the second one did not give any problems for me too (heck, I was able to play for more than 2 hours), but I have a 9 hour save in continuous mode on a medium map with no AI players that crashes after 20-30 mins.

I won't be able to test anything for a few weeks, as I'm in the middle of exams.
Posted by: hexeric
« on: June 05, 2016, 04:58:04 PM »

this problem still exists for. ANNO gives me the error message and after the 2nd or 3rd time it does it crashes. i'm on the AMD Radeon HD 6970M but i read that is might have to do with the 32bit app not playing nicely with 64bit wine and not being able to allocate RAM?
Posted by: paulthetall
« on: May 23, 2016, 08:48:18 AM »

What also might be an issue and what I see more coming up is the ratina display. Macdriver may force the resolution to that native Retina view what extremely increases the videomemory usage. So also try to lowe resolution to for Macbooks 1280x800 and IMacs 1600x900. and see how that works out.

Reason is of this theory is that I played the game for more then an hour and finished the first level and started the second one without issues.
Posted by: paulthetall
« on: May 20, 2016, 05:24:24 PM »

There will be portingkit update today which adresses intel HD GFX memory. If you guys have an Intel HD gfx card, then this update will most likely solve your problem (crashing after about 15 min. So check the news blog when it gets released and update your porting Kit straight away that time. And let us know the results.
Posted by: vitormm
« on: April 30, 2016, 05:30:02 PM »

Welp it already froze after 5 minutes! So that didn't fix it. I guess the freezing is pretty random.

Maybe, or something may be triggering this.